SNA Manage Agent Traps After Saving Configuration Change (173173)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 3.0 SP1
This article was previously published under Q173173 SYMPTOMS
After you make a configuration change using SNA Manager, the SNA Server
Manage Agent process (Mngagent.exe) may encounter an access violation,
causing the SNA Server status in Manager to appear as offline. The
SNA Server service will continue to run properly, but no status
information is displayed for the server.
When this problem occurs, the following <ntroot>\Drwtsn32.log entry is
logged:
Application exception occurred:
App: mngagent.dbg (<process ID>)
Exception number: c0000005 (access violation)
CAUSE
This problem is rare. An uninitialized variable leads to a Manage Agent
access violation in CAgtPxyRecExchange::SendModifyUse.
RESOLUTION
To resolve this problem:
- Manually restart the SNA Manage Agent (Mngagent.exe) on the SNA Server
computer.
STATUS
Microsoft has confirmed this to be a problem in SNA Server versions 3.0 and
3.0 Service Pack 1 (SP1). This problem was corrected in the latest SNA
Server version 3.0 U.S. Service Pack. For information on obtaining this
Service Pack, query on the following word in the Microsoft Knowledge Base
(without the spaces):
Modification Type: | Major | Last Reviewed: | 6/28/2004 |
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Keywords: | kbbug kbfix kbnetwork KB173173 |
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