Snacfg.exe "USER /INSERT" Fails When You Try to Add and Assign Additional LU (172299)
The information in this article applies to:
- Microsoft SNA Server 2.11, when used with:
- the operating system: Microsoft Windows NT
- Microsoft SNA Server 3.0, when used with:
- the operating system: Microsoft Windows NT
- Microsoft SNA Server 3.0 SP1, when used with:
- the operating system: Microsoft Windows NT
This article was previously published under Q172299 SYMPTOMS
When you use Snacfg.exe to assign an LU to a username, the first attempt
completes successfully. When you try to add and assign additional LUs to a
user through Snacfg.exe, the command fails with the error message:
User <username> Not Found.
If you attempt to assign the username and LU again using Snacfg.exe it
completes successfully, and in both Snacfg.exe and SNA Manager the user
shows up twice with DOMAINNAME\<username> with one configured LU for each.
CAUSE
Snacfg.exe does not parse the username entry correctly and only allows a
single LU to be assigned to a user.
RESOLUTION
Snacfg.exe has been fixed and now requires that you either prefix the
username to be assigned an LU with the DOMAINNAME or use the /DOMAIN
option. You can now successfully assign additional LUs to the same username
without creating a new account.
STATUS
Microsoft has confirmed this to be a problem in SNA Server 3.0 and 3.0
Service Pack 1 (SP1). This problem was corrected in the latest SNA
Server version 3.0 U.S. Service Pack. For information on obtaining this
Service Pack, query on the following word in the Microsoft Knowledge Base
(without the spaces):
Modification Type: | Major | Last Reviewed: | 6/29/2004 |
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Keywords: | kbbug kbenv kbfix kbnetwork KB172299 |
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