Windows 95 RPC Does Not Retry Failed Named Pipe Connections (168496)
The information in this article applies to:
- Microsoft Windows 95
- Microsoft Windows 95 OEM Service Release 1
- Microsoft Windows 95 OEM Service Release 2
- Microsoft Windows 95 OEM Service Release 2.1
This article was previously published under Q168496 SYMPTOMS
Windows 95 clients using Remote Procedure Calls (RPCs) to connect to an
endpoint over named pipes may receive the following error message:
The RPC server is unavailable. Do you wish to continue?
CAUSE
The named pipe connection code in the Windows 95 RPC run-time libraries
does not make any retry attempts after a failed named pipe connect.
RESOLUTION
This issue is resolved by the following updated file for Windows 95 and
OSR2, and later versions of this file:
RPCLTC1.DLL version 4.00.951 dated 2/13/97 8,192 bytes
A version of this file that resolves this problem is included in DCOM95 for Windows 95, version 1.3, and can be downloaded from the following Microsoft Web site:
STATUS
This problem no longer occurs in Windows 98. To resolve this problem, install the current version of Windows. For information about the current version of Windows, visit http://www.microsoft.com/windows.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbAPI kberrmsg kbnetwork kbprb kbRPC KB168496 |
---|
|