5250 Print Jobs Fail If Connection to Printer Lost/Recovered (167195)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 3.0 SP1
This article was previously published under Q167195 SYMPTOMS
AS/400 print jobs fail to print. The 5250 print session configured in SNA
Server Manager changes to a spooling state after the job is sent from the
AS/400 and the Print Manager in Windows NT may also briefly show the print
job as spooling. However, the job does not print.
CAUSE
This problem occurs after the network connection to the printer is lost
and then reestablished. The 5250 print provider does not recognize that the
connection to the printer was lost, therefore it does not reestablish its
connection to the printer. Any print jobs sent to the printer by way of the
5250 print session fail to print after the connection drop.
RESOLUTION
To work around this problem:
- Stop and restart the SNA Server Host Print service after any network
connection outage between the SNA Server and the network printer.
STATUS
Microsoft has confirmed this to be a problem in SNA Server version 3.0 and
3.0 SP1. This problem was corrected in the latest SNA Server version 3.0
U.S. Service Pack. For information on obtaining this Service Pack, query
on the following word in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Major | Last Reviewed: | 6/28/2004 |
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Keywords: | kbbug kbfix kbnetwork KB167195 |
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