Request From Perfmon Counter Can Cause Excessive Page Faults (167044)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q167044 SYMPTOMS
When you run Perfmon.exe either locally or remotely against the computer, a
constant high rate of page faults may result (perhaps 75-120 page faults
per second). Increasing the number of Perfmon sessions increases the number
of page faults.
CAUSE
The manner in which Perfmon was requesting memory can cause a continuous
loop if the performance counter requested a memory buffer that is over a
certain size to communicate with Perfmon. Because this loop is continuously
requesting new memory but is also releasing the earlier requested memory,
the pagefile usage is not impacted. This behavior has not been reproduced
using the performance counters that are included with Windows NT 4.0. This
effect only concerns performance counters that request a larger memory
buffer.
RESOLUTION
Remove the very large counters either from the registry or by
"uninstalling" the DLL that contains the performance counters.
STATUS
Microsoft has confirmed this to be a problem in Windows NT version 4.0.
This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service
Pack. For information on obtaining the service pack, query on the following word
in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Major | Last Reviewed: | 8/10/2001 |
---|
Keywords: | kbbug KB167044 |
---|
|