RAS clients run Winsock and RPC applications slowly (167038)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Server 4.0
- Microsoft Routing and Remote Access Service Update for Windows NT Server 4.0
This article was previously published under Q167038 SYMPTOMS
Remote Access Server (RAS) clients experience delays when Winsock or RPC
applications attempt to connect to remote resources.
CAUSE
The RAS Server or Routing and Remote Access Service (RRAS) Server has
provided a Domain Name Service (DNS) IP address to the client that is
unreachable. This causes Winsock and RPC applications (over TCP/IP) to fail
DNS name lookups.
By default, RAS or RRAS Servers project any DNS IP addresses they are
configured with to RAS clients using TCP/IP. If the RAS or RRAS Server has
a DNS IP address that cannot be reached by the RAS client, the RAS client
experiences delays whenever an application attempts to query the DNS name
servers. The RAS or RRAS Server may be unreachable because the DNS server
is not responding or because the RAS or RRAS Server is multihomed and the
DNS server is on a network not accessible to the RAS client.
RESOLUTION
Perform one of the following steps to resolve this problem:
Windows NT RAS ServerTo resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
Windows NT RRAS Server
Obtain the Routing & Remote Access Service Hotfix Update mentioned below.
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Microsoft has confirmed this to be a problem in Routing and Remote Access
Update for Windows NT Server version 4.0. This problem was corrected in
the Routing & Remote Access Service Hotfix Update. You can obtain this
update from Microsoft's World Wide Web Site on the Internet at the
following location:
NOTE: Because the Microsoft Web site is regularly updated, the site
address may change without notice. If this occurs, link to the Microsoft
home page at the following address:
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbAPI kbbug kbfix kbnetwork kbWinsock KB167038 kbAudDeveloper |
---|
|