XCON: MSMail Shows Blank Icon for File Attachments from Internet (161945)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
This article was previously published under Q161945 SYMPTOMS
When you are using the Microsoft Mail client or the Microsoft Exchange
Client connected to a Microsoft Mail postoffice, file attachments included
in messages from Internet users contain blank icons. This is true even for
icons that are associated with programs on the local computer. The document
does open correctly when it is clicked, if an associated program exists for
the attachment.
For example, your Microsoft Mail client shows a blank icon for an attached
Microsoft Word document, even though you have Word installed. Double-
clicking the blank icon starts Word (if it is not already started),
and the document opens correctly in Word.
CAUSE
Microsoft Mail clients display icon images according to the following
algorithms:
Winmail.dat File Does Not Exist
If an e-mail message has an attachment, and no Winmail.dat file, the
mail client will display an icon for the file if an association for the
file extension has been established. The Winmail.dat file is a special file
created by Microsoft Mail clients that contains MAPI property information,
rich-text formatting, icon images, and other non-text related items.
Winmail.dat File Does Exist
If an e-mail message has an attachment and a Winmail.dat file, the
mail client will display the icon image present in the Winmail.dat file.
The Winmail.dat file always contains an icon image for each attachment.
When mail from the Internet Mail Connector (IMC) is passed to the Microsoft
Mail Connector interchange (MSMI), the MSMI always projects a Winmail.dat
file for any message that contains an attachment. Because the original
message received by the MSMI may not contain an icon image (if it
originated from a client other than Microsoft Mail), the MSMI inserts a
blank icon image into the Winmail.dat file.
Because the Microsoft Mail client sees a Winmail.dat file (created by the
MSMI), it expects an icon image to be present.
WORKAROUND
Use either of the following methods:
Method 1: Migrate Users
Migrate users to the Microsoft Exchange Client using Microsoft Exchange
Server as their message store. In this standard configuration, Microsoft
Exchange clients will display an icon if present from the sender. If no
icon is present, the client will display an icon associated with the file
based on its associations.
Method 2: Use the Fix Described
The Status section of this article describes a fix that is available from
Microsoft Technical Support.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange versions
4.0 and 5.0.
This problem was corrected in the latest Microsoft Exchange Server 4.0 and 5.0
U.S. Service Packs. For information on obtaining the service pack, query on the
following word in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
---|
Keywords: | kbbug kbfix KB161945 |
---|
|