Interphase EISA adaptor does not support EISA bus preemption (161721)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q161721

SYMPTOMS

The Cisco/Interphase EISA FDDI/CDDI adaptors do not support EISA bus preemption. This may cause the adaptor to be incompatible with computers by using a dual/split PCI/EISA I/O bus.

The following models of Cisco/Interphase EISA FDDI/CDDI network adaptors:
  • WA-C321T-PC
  • WA-C323T-PC
  • WA-C326T-PC
  • WA-C328T-PC
can cause intermittent system resets or crashes with STOP: 0X0000000A.

Some personal computer systems that are known to exhibit this symptom include the following:
  • IBM PC Server 320 CYO
  • Compaq Proliant series (some models)
  • ALR Revolution Quad6

CAUSE

The Cisco System Workgroup Business Unit has discovered that its EISA FDDI/CDDI adaptor does not comply with the EISA Bus Preemption as described by the EISA Specification 3.12.

The Cisco EISA FDDI/CDDI adaptor does not support EISA bus preemption. This causes the adaptor to be incompatible with computers that have a dual or split EISA/PCI I/O bus.

The Interphase EISA FDDI/CDDI adaptor requires guaranteed access time (GAT) to function correctly. Personal computers that implement EISA bus preemption without also supporting GAT will experience problems. The symptom is intermittent and occurs when both the FDDI adaptor and a PCI device are active. The adaptor design predates implementation of the EISA bus preemption feature as described in EISA specification 3.12 (PCI/EISA systems shipped after 9/1/95).

In personal computers with both a PCI and an EISA bus, PCI devices are allowed access to system memory even if the EISA bus has been granted control. Because the adaptor requires GAT, and because PCI devices are able to de-assert the EXRDY (external ready) signal to the EISA bus, the adaptor will stall and not finish its transfer to memory.

The WA-C321T-PC adaptor is on the Windows NT Hardware Compatible List (HCL) and the driver is available on the \DRVLIB\NETCARD\operating system\C320NT directory of the Windows NT Server and Workstation compact discs.

Note Here, operating system is the placeholder for the name of the operating system.

WORKAROUND

If you are experiencing this problem, first contact your system vendor to see if the personal computer supports GAT mode. If the personal computer does not support GAT, consider the following two workarounds:
  • Reduce adaptor transfer burst size from 64 bytes to 32 bytes. This reduces burst transfer time and has a positive effect on some systems. This can be changed in the registry entries for the drivers (C320tnt.sys). To make this change, follow the steps listed below:

    Warning Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.
    1. Run Regedt32 and select the HKEY_LOCAL_MACHINE Window
    2. Go to SYSTEM\CurrentControlSet\Services\c320tnt1\parameters
    3. Change the "BurstSize" from 63 (3F hex) to 31 (1F hex)
  • An alternative for adding FDDI connectivity, for systems with PCI slots, is the Interphase PCI/FDDI 5511.

    Note Do not use an EISA adaptor in personal computers with active PCI devices. Use the adaptor only in personal computers that have an EISA bus.

MORE INFORMATION

Additional information can be obtained from Interphase at the following URL:

http://www.iphase.com/Public/AppEng/prodsup/c32x/EISAFDD2

Interphase Corporation
13800 Senlac
Dallas, TX 75234-8823

Technical Support: +1.214.654.5555
E-mail: intouch@iphase.com
World Wide Web: http://www.iphase.com
Anonymous FTP: ftp://ftp.iphase.com

The products discussed here are manufactured by Cisco and Interphase, vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding the products' performance or reliability.

The third-party contact information included in this article is provided to help you find the technical support you need. This contact information is subject to change without notice. Microsoft in no way guarantees the accuracy of this third-party contact information.

Modification Type:MajorLast Reviewed:12/22/2005
Keywords:kb3rdparty kbHardware KB161721