WD: Error Message: "Application Source File Cannot Be Found" (161476)



The information in this article applies to:

  • Microsoft Word for the Macintosh 6.0
  • Microsoft Word for the Macintosh 6.0.1
  • Microsoft Word 98 Macintosh Edition

This article was previously published under Q161476

SYMPTOMS

When you attempt to insert or edit an embedded object from within Microsoft Word, you may receive the following error message:
The server application, source file, or item cannot be found. Make sure the application is properly installed, and that it has not been deleted, moved, or renamed.

CAUSE

Several things can cause this error, including missing or deleted programs from the Microsoft folder, a desktop error, a corrupted Embedding Preferences or Registration Database files, a shortage of memory, or problems with the system software.

RESOLUTION

To troubleshoot this problem, follow these steps:
  1. Rebuild the desktop with extensions off. To do this, restart your computer while pressing the Command and OPTION keys.

    Note that on System 7.5 and later it is important to turn off all extensions except the "Macintosh Easy Open" control panel before restarting with the Option and Command keys pressed, or a complete rebuild of the desktop will not occur.

    For additional information, please see the following article in the Microsoft Knowledge Base:

    123913 Rebuilding the Desktop with System 7.5



  2. Upon restart, make certain virtual memory (or Ram Doubler) is operating. To do this, follow these steps:

    a. On the Apple menu, point to Control Panels and click Memory.

    b. In the Memory dialog box, under Virtual Memory, click On.

    c. Close the Memory dialog box.

    For additional information, please see the following articles in the Microsoft Knowledge Base:

    120506 How Virtual Memory Works on a Power Macintosh



  3. If the error is still occurring, move the following files from the System:Preferences folder to the desktop

    • Embedding Preferences
    • PPC Registration Database
    • Registration Database
    and then reinstall Word (or Office) on your computer.

    For additional information, please see the following articles in the Microsoft Knowledge Base:

    124063 Don't Delete Settings/Preferences Files When Troubleshooting

  4. If these steps fail, the Macintosh Finder may be corrupted. Perform a clean reinstallation of your system.

    For additional information, please see the following article in the Microsoft Knowledge Base:

    127033 How to Do a Clean Installation of System 7.5


Modification Type:MajorLast Reviewed:10/4/2002
Keywords:kberrmsg KB161476