Custom Message Changes Not Replicated in Outlook/Schedule+ (161321)



The information in this article applies to:

  • Microsoft Team Manager

This article was previously published under Q161321

SYMPTOMS

You have customized your mail messages to team members to prevent them from making adjustments to fields, such as Priority. The restrictions appears in Microsoft Team Manager for team members, but do not appear in Microsoft Outlook or Microsoft Schedule+. You can still make modifications to the field.

CAUSE

Microsoft Team Manager custom message changes, such as field additions, deletions, and restrictions are not replicated to Microsoft Outlook and Schedule+.

STATUS

This behavior is by design.

MORE INFORMATION

Microsoft Team Manager enables you to customize the mail messages that are sent to team members. Customization includes adding and removing fields and also placing restrictions on fields so that team members can view, but not change data.

Microsoft Team Manager for Team members properly shows customization sent from the manager. However, Microsoft Outlook and Microsoft Schedule+ do not support all of the fields that Team Manager has, nor the ability to "lock" fields from user input. Therefore, these changes do not appear in Microsoft Outlook or Schedule+.

If a team member uses either Schedule+ or Outlook to track tasks, the team member will have to manually add or remove fields as necessary. A team member will be able to make changes in restricted fields, but these changes will never get sent to the team manager.

To understand how this process works, consider the following example using Microsoft Outlook.

NOTE: The following example assumes that the team manager has already sent a team settings message to the team member, that at least one task has been accepted by the team member, and that the synchronization option in Microsoft Team Manager for team members is set to work with Microsoft Outlook.

Team Manager

  1. On the Tools menu, click Customize Messages.
  2. In the Customize Messages dialog box, under "Columns in task lists," click Priority.
  3. Click to clear the "Let team members edit this column" check box.
  4. Click OK. Click Yes to "Do you want to send these changes to your team now" message.
  5. In the Team Member Settings dialog box, click Send.

Team Member

  1. In your mail inbox, open the message sent from the team manager.
  2. Accept the message.

    NOTE: In Microsoft Team Manager for team members that the Priority field is visible, but not editable.
  3. In Microsoft Outlook, click your Tasks list.

    NOTE: The Priority field is not disabled as it is in Microsoft Team Manager for team members.
  4. Change the priority of a task; the default is medium and you can choose either high or low.
  5. On the Tasks menu, click Send Updates. Click Next.

    A message appears explaining that no changes to your tasks have been made since you last sent an update to your manager.
  6. Open Microsoft Team Manager for team members.
Notice that the priority has not changed for the task you changed in Microsoft Outlook.

Had the priority field in this example not been restricted, the change would be sent to the manager and would update your personal task list.

The following table shows Team Manager custom message fields and whether they allow restrictions - the ability to prevent team members from changing data in the field:
    Field Name                    Restrictions
    ------------------------      ------------
    Actual and Remaining Work     No
    Alert                         Yes
    Billing Information           Yes
    Completed                     No
    Description                   Yes
    Deadline                      Yes
    Earliest Start                Yes
    Marked                        Yes
    Misc. Costs                   Yes
    Notes                         No
    Priority                      Yes
    Project                       Yes
    Status                        No
    Task Name                     No
				
Any custom field except Memo and OLE Object types may be added to messages and can be restricted by the manager.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:KB161321