PRB: Setup Unable to Register an .ocx File Error (160771)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 5.0
This article was previously published under Q160771 SYMPTOMS
When using setup disks created by the Setup Wizard to install an executable
file, the set up process does not complete because the following error
appears:
<filename.ocx> was unable to register itself in the System Registry
followed by the message:
Setup not completed successfully.
The Setup process then terminates.
CAUSE
The Setup program is unable to register the .ocx file because it is
corrupted or the incorrect version.
RESOLUTION
Ensure that the .ocx file is located in the same folder as the executable
file before the Setup Wizard compresses the files.
Next, check the version of the .ocx file being used with the executable
file against the corresponding .ocx file located in the either the
Windows\System or Windows\System32 folder. On Windows 95, the
Windows\System folder contains the .ocx files that shipped with Visual
FoxPro 5.0. On Windows NT 3.51 or 4.0, they reside in the Windows\System32
folder. To determine the version of an .ocx file, on Windows 95 or Windows
NT 4.0, start Windows Explorer or My Computer, highlight the .ocx file,
right-click (secondary click) and click Properties on the menu that
appears, and press the Version tab. On Windows NT 3.51, highlight the file,
and press the Alt and Enter keys.
The General tab provides information on the file size in bytes. This
information is useful if you suspect file corruption. Again, compare the
file being compressed with the file in the appropriate Windows\System
folder.
REFERENCES
For more information about the ActiveX Controls Overview Help topic,
please see the following article(s) in the Microsoft Knowledge Base:
157193 DOCERR: ActiveX Controls Help Topic Lists Incorrect File
Modification Type: | Major | Last Reviewed: | 3/9/2000 |
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Keywords: | kberrmsg kbprb kbsetup KB160771 kbAudDeveloper |
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