XADM: MTA Does Not Deliver Messages with High Directory Service Activity (159184)
The information in this article applies to:
- Microsoft Exchange Server 4.0
This article was previously published under Q159184 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
You may have difficulty delivering messages with the Microsoft Exchange Server
message transfer agent (MTA). The symptoms for this problem are as follows:
- The directory service is consistently very busy (processor use is
20 percent or greater).
- MTA processor usage is quite low.
- The MTA work queue consistently has a backlog of messages.
- Messages are not delivered to the server.
- The global address list is very large (20,000 users or more).
CAUSE
This problem is caused by time consuming fuzzy proxy directory service
searches on large global address lists.
RESOLUTION
Apply the fix mentioned in the "Status" section of this article. If this fix does not correct the problem, perform
one of the following steps:
- Create the Allow fuzzy proxy search registry value and set it to 2. To do this, you need to edit the registry.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
- Start Registry Editor (Regedt32.exe).
- Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:
SYSTEM\CurrentControlSet\Services\MSExchangeMTA\Parameters - Define the following registry value:
Set this value to 2. This case-sensitive registry value is a DWORD value type.
If you set the Allow fuzzy proxy search value to 2, you disable the fuzzy proxy search. If
this registry value does not exist, the MTA assumes that this setting has
a value of 1, and enables fuzzy proxy searches.
- Quit Registry Editor.
- If the problem persists, disable the alternate recipient Redirect
and Deliver option for every mailbox on the server. To do this, in each mailbox, click the Delivery Options tab, and under Alternate
Recipient, click None.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange Server,version 4.0.
This problem was corrected in the latest Microsoft Exchange 4.0 U.S.
Service Pack. For information on obtaining the service pack, query on the
following word in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbbug kbfix KB159184 |
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