SysAdmin Installs Incorrectly from Normandy Beta 2 CD (158988)
The information in this article applies to:
- Microsoft Commercial Internet System 1.0
This article was previously published under Q158988 SYMPTOMS
After loading the web-based administration tools for Microsoft Commercial
Internet System (MCIS) Membership Server, any or all of the following
behavior may be noted:
- *_sso.dll errors on the server running the web-based administration
tools.
- Visual Basic Script errors on the client when browsing the administrator
pages.
- Slow response from the server when browsing the administrator pages.
CAUSE
The setup for the systems administrator on the Beta 2 compact disc has some
errors regarding where certain files are placed. There is also a security
issue to resolve, due to the locations of the .asp and .dll files.
RESOLUTION
To resolve this problem:
- Change the alias for /normadmin as listed in the WWW service from
C:\Program files\normandy\webadmin
to
C:\Program files\normandy\webadmin\sysadmin - Remove the Anonymous option in the WWW service, or create an ACL that
will require NTLM authentication for accessing /normadmin.
- At the MS-DOS prompt, run the command
copy c:\program files\normandy\membership\*.dll c:\winnt\system32
This puts the .DLLs in the correct place.
MORE INFORMATION
This can be a very complex issue, due to security access for these tools.
This tool-set directly edits the SQL database "security," which is set up
for the Membership Agent (backend). The Commercial Internet System
documentation recommends that the client running these scripts be
restricted to within the Data Center, although it also notes that you can
set this up to run remotely.
When making changes to your security settings, take into consideration how
much you are exposing your database to intrusion.
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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Keywords: | KB158988 |
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