DC Agent Set to Automatic but Fails to Start (158421)
The information in this article applies to:
- Microsoft Commercial Internet Server 1.0
This article was previously published under Q158421 SYMPTOMS
When MSSQL Server service and the DC Agent service are on the same
computer, DC Agent doesn't start, even though it's set on automatic.
It also does not give a "service failed to start" warning. Typically, the
Application log (Event viewer) will contain the following entry:
Initializing buffers and connections to Membership Backend SQL server
failed.
CAUSE
This problem occurs because the MSSQL Server service takes longer to load
than the DC Agent service (on most computers). Since the SQL Server
isn't up when the Agent service calls for it, the Agent fails to start.
WORKAROUND
Obtain a copy of the file Sc.exe from the WIN32 software development kit
(SDK) and place it in your \winnt subdirectory. From a command prompt, type
the following command:
sc config sicserv depend= mssqlserver
(Note the required space after the "=".)
Doing this will cause the Agent service to wait until after it has
confirmed that the SQL service has started.
STATUS
It has been determined that since this configuration (Agent and SQL on the
same computer) is not supported, no changes to the code are required to fix
this issue. This documentation serves to provide an answer to this problem
for those who still may try to run this scenario.
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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Keywords: | KB158421 |
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