Errors in Appman.log After Running NADRESET (153108)
The information in this article applies to:
- Microsoft Systems Management Server 1.0
- Microsoft Systems Management Server 1.1
This article was previously published under Q153108 SYMPTOMS
After you detach a child site from a parent site and run Nadreset.exe,
Appman.log will report errors similar to the following:
ERR ##> Error getting package <package id> from source (SQL).
If SQL tracing is turned on the error appears after a select statement
to the Packages table querying the package ID. A query to the packages
table shows that the package no longer exists in the database.
CAUSE
Applications Manager looks in the registry in the HKEY_LOCAL_MACHINE
subtree at the following subkey:
\Software\SMS\Components\SMS_DESPOOLER\Master Packages
for the list of packages to search for in the database. Nadreset.exe does
not delete the package keys from the registry although it does remove them
from the database.
RESOLUTION
WARINING: Using Registry Editor can cause serious, system-wide problems
that may require you to reinstall Windows NT to correct them. Microsoft
cannot guarantee that any problems resulting from the use of Registry
Editor can be solved. Use this tool at your own risk.
Deleting the package ID keys will alleviate the errors in the APPMAN.LOG.
- Run the Registry Editor (REGEDT32.EXE).
- Under the HKEY_LOCAL_MACHINE subtree go the following subkey:
\Software\SMS\Components\SMS_DESPOOLER\Master Packages.
- Delete the package ID keys.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server
versions 1.0, 1.1, and 1.2.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
---|
Keywords: | kbArtTypeINF kbnetwork kbPCM kbSMSAppMan KB153108 |
---|
|