TMGR: Unique Task ID Is Reused in Some Cases (151138)



The information in this article applies to:

  • Microsoft Team Manager

This article was previously published under Q151138

SYMPTOMS

When a task in Microsoft Team Manager is archived, the task is removed from the Team Manager Organizer View. If you then paste the task back into the file, the task will have the same Unique ID as the archived task. The same behavior can be achieved if you copy a task, delete the same task, and then paste the task into the same line. The unique task ID number is retained.

This is an exception to the rule that a new, unique ID is created for each new task. For example, if you copy a task and paste it into another task line, it gets a new, unique ID.

CAUSE

These are both special cases where the unique ID is retained by design. This will not cause a problem of duplicate unique ID numbers because new tasks are never assigned previously used unique ID numbers.

WORKAROUND

If you need to delete a task and generate a new, unique ID task, copy the original and paste it to another line.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:KB151138