XADM: Reversed Display Names May Not Be Resolved (147508)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q147508 SYMPTOMS
When a first name such as 'Mary Anne' and a surname for a known recipient
is typed on the TO: line in a Microsoft Exchange Client, the name is not
resolved.
CAUSE
This problem occurs if the display name for the user is reversed as
follows:
User: Mary Anne Smith
Display Name: Smith, Mary Anne
When 'Mary Anne Smith' is typed on the TO: line, the display name is first
referenced in order to resolve the address. In this case it will fail as
the display name is 'Smith, Mary Anne'. The next phase will compare the
typed name to the surname and given name of the recipient which is entered
as first name 'Mary Anne' and last name 'Smith' in the order of last name
first.
Due to the embedded space between 'Mary Anne', Exchange will simply see the
name as 'Anne Smith' and the name resolution will fail.
This would not be the case if the name were 'Mary Smith' as Exchange would
be able to see both the first and last names properly.
WORKAROUND
If your system is configured to use reversed display names, the recommended
option would be to enter the first name as simply 'Mary' and use 'Anne
Smith' as the last name on the user's mailbox properties in the Microsoft
Exchange Administer program. This will result in the name being properly
resolved when 'Mary Anne Smith' is typed on the TO: line in a Microsoft
Exchange Client.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbprb kbusage KB147508 |
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