FIX: Unhandled Exception When Running DBCC Checkdb (147414)
The information in this article applies to:
This article was previously published under Q147414
BUG# NT: 13125 (6.00)
SYMPTOMS
When running DBCC CHECKDB or CHECKTABLE, SQL Server may encounter an
unhandled exception.
The last message in the errorlog prior to the exception will be the
following:
96/01/25 15:34:31.63 kernel
upinit: warning, unable to raise priority of dbcc-worker thread
If you are running Service Pack 2, the above message will be followed by:
96/01/25 15:34:31.72 kernel
upinit(dbcc-worker) failed: error code: 0x5
(5(Access is denied.))
CAUSE
This problem will only occur if SQL Server is running in Per Seat licensing
mode and is configured to use standard security, and even under these
conditions, it is rare.
WORKAROUND
You can work around this problem by doing one of the following:
- Switch the SQL Server security mode to mixed or integrated security.
- Use SQL Server trace flag 2508 to disable parallel non-clustered index
checking for DBCC CHECKTABLE. This has little performance impact on most
servers, because to benefit from parallel checktable you must have
buffer cache larger than the size of the table being checked.
STATUS
Microsoft has confirmed this to be a problem in Microsoft SQL Server
version 6.0. This problem has been corrected in U.S. Service Pack 3 for
Microsoft SQL Server version 6.0. For more information, contact your
primary support provider.
Modification Type: | Major | Last Reviewed: | 3/26/1999 |
---|
Keywords: | kbusage KB147414 |
---|
|