PPT7: PowerPoint Encountered an Error That It Could Not Correct (141247)



The information in this article applies to:

  • Microsoft PowerPoint for Windows 95

This article was previously published under Q141247

SYMPTOMS

You may receive one of the following error messages in Microsoft PowerPoint:
PowerPoint encountered an error that it could not correct.

-or-

PowerPoint caused an invalid page fault in module Kernel32.dll.
In most cases, you receive either of these errors when you click the Tools menu, or when you attempt to use any of the following features in PowerPoint:
  • AutoClipart
  • AutoContent Wizard
  • Genigraphics Wizard
  • Interactive Settings
  • Internet Assistant (Add-In)
  • Meeting Minder
  • Pack and Go
  • Presentation Conferencing
  • Rehearsal
  • Slide Meter
  • Slide Navigator
  • Style Checker
  • Write-Up

CAUSE

There are several possible causes. The following is a list of each known cause:
  • This problem may occur because Visual Basic for Applications files on your system are missing or corrupted, or you have invalid registry settings.

    -or-

  • This problem may occur if you are using an incompatible Winsock.dll file, Wsock32.dll file, or a third-party TCP/IP protocol instead of the Windows-95-supplied TCP/IP protocol. If you suspect that you have a third-party TCP/IP protocol installed, see the "More Information" section later in this article for a possible fix.

    -or-

  • This problem may occur if you click on the File menu while you have one or more presentations minimized. This occurs mostly with notebook computers, and some desktop computers with local installations of PowerPoint, version 7.0, running on Windows 95. This problem does not occur on Windows 98, or "Run from Server" installations of PowerPoint. There is no resolution for this problem.

RESOLUTION

To resolve this problem, try the following steps:
  1. Rename the Ppttools.ppa, Ppttools.dll and Ppttoolr.dll files. These files are located in the PowerPoint folder.
  2. Start PowerPoint Setup and click Reinstall Current Installation.
If this does not resolve the problem, rename the following files and perform a complete reinstall of Microsoft Office or PowerPoint:
  • Vba32.dll
  • Vbaen32.dll
  • Vbaen32.olb
  • Ppttools.ppa
  • Pptools1.ppa

MORE INFORMATION

If none of the other methods in the "Resolution" section of this article resolve the problem, Microsoft also offers an Application Note titled "DLL to Fix PowerPoint Tools Menu" (WT1274). This Application Note contains a file that prevents PowerPoint from not responding if you click the Tools menu when third-party TCP/IP protocol stacks are installed.

The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kbdownload kbdta kbenv kberrmsg kbfile kbGraphxLink kbprb KB141247