L2GETNET Causes Access Violation Error on Windows 95 Clients (140927)
The information in this article applies to:
- Microsoft Systems Management Server 1.0
- Microsoft Systems Management Server 1.1
This article was previously published under Q140927 SYMPTOMS
L2GETNET causes an access violation or sharing violation error on Windows
95 clients.
CAUSE
L2GETNET.EXE determines the IP address of a Windows 95 client by calling
WINIPCFG.EXE in batch mode and redirects the output to a temporary file
(IPCONFIG.SMS). This file is then scanned for IP parameters like IP
Address, Subnet Mask and Default Gateway. On some computers, especially
slower ones, an access violation might occur, as it is possible that
WINIPCFG.EXE hasn't finished storing data in IPCONFIG.SMS. So while
WINIPCFG.EXE is in progress of writing it's data, L2GETNET.EXE attempts to
read the file which results in the error.
RESOLUTION
Microsoft has modified the files, L2GETNET.EXE, WINIP95.EXE, and
GETTCPIP.EXE, to correct this problem. INVDOS.EXE and START.EXE are also
included with the fix. To apply the fix:
- Copy L2GETNET.EXE, INVDOS.EXE and GETTCPIP.EXE to the
<sms>\SITE.SRV\MAINCFG.BOX\CLIENT.SRC\X86.BIN directory. From there it
is distributed to all logon servers.
- Copy START.EXE and WINIP95.EXE to the client's \ms\sms\bin directory.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server
version 1.1. A supported fix is now available, but has not been fully
regression-tested and should be applied only to systems experiencing this
specific problem. Unless you are severely impacted by this specific
problem, Microsoft recommends that you wait for the next Service Pack that
contains this fix. Contact Microsoft Product Support Services for more
information.
This problem has been corrected in Systems Management Server version 1.2.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbArtTypeINF kbInventory kbnetwork KB140927 |
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