Cannot Type User Name or Password Logging on as a Different User (140257)



The information in this article applies to:

  • Microsoft Windows 95

This article was previously published under Q140257

SYMPTOMS

If you add a new keyboard layout while user profiles are enabled, and then choose the "Close all programs and log on as a different user" option in the Shut Down Windows dialog box, the keyboard may stop responding (hang).

CAUSE

User.exe creates a window/queue for the login box so early that the system does not realize it is using an unusable language. The language is unusable because the other language files have not been loaded yet.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

This fix should have the following file attributes or later:
   USER.EXE  version 4.00.951  dated 10/26/95 9:51am  461,984 bytes
				

This update is currently available in the following localized versions:
  • English
  • French
  • German
  • Dutch
  • Portuguese (Brazil)
To work around this problem, restart your computer after you add a new keyboard layout. To do so, click Start, click Shut Down, click Shut Down, and then click OK.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95 and OEM Service Release 2 (OSR2). An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.

This issue is resolved in Microsoft Windows 98.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following article in the Microsoft Knowledge Base:

180727 Error Message: Property or Method Not Found

182053 BUG: LSTRCMP and LSTRCMPI May Fail with Non-US Regional Settings


For additional information about Windows 95 updates, please see the following article in the Microsoft Knowledge Base:

161020 Implementing Windows 95 Updates


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbenv kbprb KB140257