RAS Error: "The communications device attached to port..." (139364)
The information in this article applies to:
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q139364 SYMPTOMS
You receive one or more occurrences of the following error message in the
System Log of the Windows NT Event Viewer:
Event ID: 20015
Source: RemoteAccess
Description: The communications device attached to port COMX is not
functioning.
NOTE: X represents the number of a COM port.
Additionally, the Port Status option of the Remote Access Admin utility
reports the following for the COM port:
Modem Condition: Hardware failure
Line Condition: Line non-operational
CAUSE
You have configured RAS to allow dial-in for one or more modems with a
device name equal to 32 characters in length. This problem will likely
appear if you are using a multiport serial adapter and multiple ports are
configured for devices with names equal to 32 characters. The error message
may not appear for all ports configured with a device name equal to 32
characters.
RESOLUTION
Edit the device name in %SystemRoot%\system32\ras\MODEM.INF so that it is
no more than 31 characters in length. Although the documented limit to the
length of a device name in MODEM.INF is 32 characters, using less than 32
characters solves the problem. Use the following steps to workaround this
problem:
- Open %SystemRoot%\system32\ras\MODEM.INF in a text editor.
- Find the section in MODEM.INF that corresponds to your modem. This
section will be identified by the name of the modem enclosed in square
brackets.
- Modify the name of the modem so it is no more than 31 characters in
length. The open and close square bracket characters do not count as one
of the 31 characters.
- Save MODEM.INF.
- Open the Network section of Control Panel.
- Configure the Remote Access Service.
- Choose the Configure button and select the new device name entered in
step 3, then choose OK.
- Choose Continue, then choose OK.
- Shutdown and restart Windows NT.
STATUS
Microsoft has confirmed this to be a problem in Windows NT version 3.51. We
are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
Modification Type: | Major | Last Reviewed: | 8/8/2001 |
---|
Keywords: | kbenv KB139364 |
---|
|