FoxPro Hangs Accessing Database on Macintosh Volume (139168)



The information in this article applies to:

  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51

This article was previously published under Q139168

SYMPTOMS

If you attempt to write large amount of information to a FoxPro database stored on a Macintosh volume in Windows NT Server, the following occurs on the client computer:
  • FoxPro application stops responding (hangs).
  • Access to the FoxPro database is not available.

CAUSE

Resource forks are generated as data is written to the FoxPro database on the Macintosh volume. Each time data is written to the database, Windows NT blocks access to the Macintosh volume in order to enumerate the changes for Macintosh users. If many workstations attempt to write to the database at the same time, FoxPro times out internally. Network Keepalive traffic is generated and the workstations stay connected to the server. However, access to the database is interrupted for a significant period of time.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 3.51. This problem was corrected in the latest US Service Pack for Windows NT. For information on obtaining this update, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:10/23/2003
Keywords:kbnetwork KB139168