FPNW Server Fails to Replicate Files to NetWare Clients (137501)



The information in this article applies to:

  • Microsoft Windows NT Server 3.51
  • Microsoft File and Print Services for NetWare 3.51

This article was previously published under Q137501

SYMPTOMS

When you use IBM LAN Bridge Manager version 2.0 with File and Print Services for NetWare (FPNW) 3.51, the FPNW server fails to download and update files on the NetWare client computer (using NETX or VLM).

CAUSE

When the shareable flag is returned as "yes" for replicating files, the IBM Lan Bridge Manager software does not copy some of the server based files to the client.

RESOLUTION

To correct this problem:

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

  1. Run Registry Editor (REGEDT32.EXE).
  2. From the HKEY_LOCAL_MACHINE subtree, go to the following key:

    \SYSTEM\CurrentControlSet\Services\FPNW\Parameters
  3. From the Edit menu, select Add Value.
  4. Add the following:

    Value Name: ReturnShareableFlag
    Data Type: REG_DWORD
    Data: 0
  5. Choose OK and quit Registry Editor.
  6. Shutdown and restart Windows NT.

Modification Type:MajorLast Reviewed:11/4/2003
Keywords:KB137501