Winsock Application Hangs Using TCP/IP-32 (135453)



The information in this article applies to:

  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11
  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11a
  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11b

This article was previously published under Q135453

SYMPTOMS

If a Winsock application creates a window (hidden or not) to process connection messages from a non-blocking socket, the application may stop responding (hang) on the second connection attempt.

CAUSE

If a Winsock application creates a window to processes Winsock messages for the connection, and the application deletes the window before the socket is closed, the application may appear to hang if it attempts to establish a new connection. Because the socket was not closed before the window was deleted, additional Winsock messages may be generated. Because the window that these Winsock messages are destined for no longer exists, the messages are undeliverable. These undelivered messages cause the application to hang.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:KB135453