Clients Cannot Run NetWare System Utilities Through GSNW (126241)
The information in this article applies to:
- Microsoft Windows NT Server 3.1
- Microsoft Windows NT Workstation 3.1
- Microsoft Windows NT Advanced Server 3.1
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Server 3.5
- Microsoft Windows NT Server 4.0
This article was previously published under Q126241 SYMPTOMS
If a client computer is connected to a NetWare server shared by Gateway
Service for NetWare (GSNW) on a Windows NT Server, you cannot use any of
the supported NetWare system utilities (Syscon, PConsole, Whoami, Filer,
etc.) or NetWare-aware applications from the client computer.
CAUSE
The NetWare system utilities and NetWare-aware applications use NetWare
client application program interface (API) calls. A client computer
connected to a shared NetWare resource through a Windows NT Server running
GNSW, sends and receives information through a Server Message Block (SMB)-
based redirector that cannot interpret any of the NetWare API calls or NCP
packets. Client Service for NetWare and Gateway Service for NetWare
interpret NetWare API calls through NWRDR.SYS, but only for local
processes.
RESOLUTION
To run the NetWare system utilities and NetWare-aware applications
on the client computer:
- If the client computer is a Windows NT Workstation, install the
Client Service for NetWare.
- If the client computer is using an operating system other than
Windows NT, install the NetWare drivers and redirectors in real mode
according to the following conditions:
- If you are using Novell NetWare to work with IPXODI.COM, add
the following lines to your AUTOEXEC.BAT file:
LSL
<appropriate ODI driver for your network card>
IPXODI
NETX /ps=<preferred server name>
- If you are using Novell NetWare to work with IPX.COM, add the
following lines to your AUTOEXEC.BAT file.
IPX
NETX /ps=<preferred server name>
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
---|
Keywords: | kbnetwork KB126241 |
---|
|