ACC2: ORA-00942 Error Opening Attached ORACLE Table (121833)
The information in this article applies to:
This article was previously published under Q121833 SYMPTOMS
When you attach an ORACLE table using one login ID and password, and then
attach a second ORACLE table using a different login ID and password, you
may receive the following error messages when you try to open the second
attached ORACLE table:
Couldn't execute query; couldn't find linked table
[Page Ahead][ODBC Oracle Driver][Oracle OCI]ORA-00942: table or
view does not exist.[#942]
Can't open table in Datasheet view
CAUSE
This behavior is caused by the way the Microsoft Jet database engine shares
connections to remote databases. You will receive the error messages stated
above under the following conditions:
- You have two user accounts set up on the ORACLE server. The first
account does not have select rights granted on at least one of the
tables created by the second user account.
- You attach and open any table using the first user account.
- Using the second user account, you close the first table and attach a
table that is not accessible by the first user account.
When you try to open the second table, Microsoft Access will try to open
the table using the first account's login information.
RESOLUTION
Create another ODBC data source for the same server and database. When you
attach the second table, select this new data source. Choosing the new data
source will create a separate connection to the same server, preventing the
Microsoft Jet database engine from sharing the connection.
STATUS
This behavior is by design. Changes to this behavior are being reviewed
and will be considered for inclusion in a future release of Microsoft
Access.
MORE INFORMATION
ORACLE is manufactured by Oracle Corporation, a vendor independent of
Microsoft; we make no warranty, implied or otherwise, regarding this
product's performance or reliability.
Modification Type: | Minor | Last Reviewed: | 1/26/2005 |
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Keywords: | kberrmsg kbinterop kbprb KB121833 |
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