Works: Menu Options Stop Working After Saving or Opening File (112685)
The information in this article applies to:
- Microsoft Works 3.0
- Microsoft Works 3.0a
- Microsoft Works 3.0b
This article was previously published under Q112685 SYMPTOMS
After you open or save a document for the first time, you may find that
most menu commands are unavailable. For example, choosing Font & Style
from the Format menu or Options from the Tools menu may result in no
action, while Save and Print in the File menu may work correctly.
Furthermore, if you open the file from the Startup dialog box's Recently
Used Files list or directly from File Manager, the menu commands will be
available until you choose Open Existing File or Save As from the File
menu.
Highlighting may also become inconsistent. Rather then being able to select
a word at a time, the minimum may be a sentence or a paragraph at a time.
NOTE: This can also be caused by a Control key on the keyboard being stuck.
CAUSE
This problem is caused by an outdated or beta version of COMMDLG.DLL,
the library used by Windows-based applications to draw the standard Open,
Save, Print, Print Setup, Font & Style, and Color dialog boxes on
the screen. This file is located in either the Windows directory
or the Windows SYSTEM subdirectory.
RESOLUTION
Use the following steps to resolve the problem:
Windows 3.x- Start File Manager (usually located in the Main group).
- From the View menu, choose All File Details.
- From the File menu, choose Search.
- In the Search For box, type commdlg.dll
and enter the path to your hard disk drive in the Start From box (for
example, type C:\ if your hard drive is
drive C).
- Compare the file sizes and dates with the following table:
Windows Version File Date File Size Disk
------------------------------------------------------
3.1 3/10/92 89248 bytes 4
3.11 11/1/93 97936 bytes 1 - Verify that the correct version of the file is in the Windows SYSTEM
subdirectory. If it is not there, or the file size and/or date is
different than those listed in this table, then exit Windows to MS-DOS
and use the following command to expand the file from the original
Windows disk (shown above):
expand a:commdlg.dl_ c:\windows\system\commdlg.dll - Verify that the file is not included in the Windows directory. If
it is present in the Windows directory, rename it using the
following command:
rename commdlg.dll commdlg.old - Restart Windows and test Works. It should operate correctly now.
Windows 95- Click the Start button, point to Find, then click Files or Folders.
- In the View menu, choose Details.
- In the Named box, type commdlg.dll
and enter the path to your hard disk drive in the Look In box (for
example, type C:\ if your hard drive is
drive C). Then click the Find Now button.
- Compare the file sizes and dates with the following:
File File Cabinet Location
Date Size File Disk CD
---------------------------------------------------------------
7/11/95 97936 bytes Precopy1.cab disk 1 Win95 Folder
To find the exact file size, click on the file with the secondary mouse
button and choose properties.
- Verify that the correct version of the file is in the Windows SYSTEM
subdirectory. If it is not there, or the file size and/or date is
different than those listed in step 3, then open a DOS window by
clicking Start, point to Programs, and click MS-DOS prompt.
- Use the following command to extract the file from the Precopy1.cab
cabinet file (see the location above)
extract /L c:\windows\system <path>\precopy1.cab commdlg.dll
where <path> is the complete path to the precopy1.cab file on the
Windows 95 CD or diskette.
- Verify that the file is not included in the Windows directory. If
it is present in the Windows directory, rename it using the
following command:
rename commdlg.dll commdlg.old - Restart Windows and test Works. It should operate correctly now.
Modification Type: | Major | Last Reviewed: | 9/25/2003 |
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Keywords: | KB112685 |
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