Windows NT Screen Savers Fail to Run Smoothly (102503)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1

This article was previously published under Q102503

SYMPTOMS

Screen savers run slowly or jerkily under Windows NT.

CAUSE

This problem occurs when an application calls the PeekMessage application program interface (API) functions even when it's apparently idle. Borland's Quattro Pro for Windows and Microsoft Word for Windows both do this.

RESOLUTION

By default, Windows NT gives a priority boost to the program with the input focus. If Quattro Pro for Windows or Word for Windows is taking all the CPU time (when you want a background application to get more CPU time), disable the input focus boost. You can do this through the System icon in Control Panel.

Modification Type:MajorLast Reviewed:11/20/2003
Keywords:kb3rdparty KB102503