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Migrating Compaq Servers in a
Windows NT 4.0 Environment

Abstract:  The purpose of this white paper is to provide standard
procedures and information necessary when migrating Compaq
Server hardware platforms with the Windows NT operating system
installed.

The information presented in this document is intended for system,
hardware, field service and/or network engineers and administrators
involved in migrating or upgrading Compaq servers running
Windows NT.

This document provides:

• Migration checklist and example migration data form to assist
with the migration/upgrade.

• Step-by-Step instructions necessary to prepare your software for
the migration/upgrade process.

• Step-by-Step instructions necessary to prepare your system or
hardware for the migration/upgrade process.

• Troubleshooting strategies and sample error messages that may
occur during or after a hardware migration.

This white paper is intended for use in conjunction with information
and documentation specific to the Compaq server migration being
performed.  It can be used as a guideline and does not provide
specific information for a particular migration or upgrade.  Before
using this white paper search for documentation specific to your
needs.

Note:  All results are based on Windows NT 4.0, results may or
may not be applicable on other versions of Windows NT.
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Notice
The information in this publication is subject to change without notice and is provided “AS IS” WITHOUT
WARRANTY OF ANY KIND.  THE ENTIRE RISK ARISING OUT OF THE USE OF THIS
INFORMATION REMAINS WITH RECIPIENT.  IN NO EVENT SHALL COMPAQ BE LIABLE FOR
ANY DIRECT, CONSEQUENTIAL, INCIDENTAL, SPECIAL, PUNITIVE OR OTHER DAMAGES
WHATSOEVER (INCLUDING WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS
PROFITS, BUSINESS INTERRUPTION OR LOSS OF BUSINESS INFORMATION), EVEN IF
COMPAQ HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

The limited warranties for Compaq products are exclusively set forth in the documentation accompanying
such products.  Nothing herein should be construed as constituting a further or additional warranty.

This publication does not constitute an endorsement of the product or products that were tested.  The
configuration or configurations tested or described may or may not be the only available solution.  This test
is not a determination or product quality or correctness, nor does it ensure compliance with any federal
state or local requirements.

Product names mentioned herein may be trademarks and/or registered trademarks of their respective
companies.

Compaq, Contura, Deskpro, Fastart, Compaq Insight Manager, LTE, PageMarq, Systempro, Systempro/LT,
ProLiant, TwinTray, ROMPaq, LicensePaq, QVision, SLT, ProLinea, SmartStart, NetFlex, DirectPlus,
QuickFind, RemotePaq, BackPaq, TechPaq, SpeedPaq, QuickBack, PaqFax, Presario, SilentCool,
CompaqCare (design), Aero, SmartStation, MiniStation, and PaqRap, registered United States Patent and
Trademark Office.

Netelligent, Armada, Cruiser, Concerto, QuickChoice, ProSignia, Systempro/XL, Net1, LTE Elite,
Vocalyst, PageMate, SoftPaq, FirstPaq, SolutionPaq, EasyPoint, EZ Help, MaxLight, MultiLock,
QuickBlank, QuickLock, UltraView, Innovate logo, Wonder Tools logo in black/white and color, and
Compaq PC Card Solution logo are trademarks and/or service marks of Compaq Computer Corporation.

Microsoft, Windows, Windows NT, Windows NT Server and Workstation, Microsoft SQL Server for
Windows NT are trademarks and/or registered trademarks of Microsoft Corporation.

NetWare and Novell are registered trademarks and intraNetWare, NDS, and Novell Directory Services are
trademarks of Novell, Inc.

Pentium is a registered trademark of Intel Corporation.
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Executive Overview
Compaq customers are assured investment protection for their enterprise servers today and in the
future for the ProLiant line of servers.  Today’s computing environments call for systems built for
high performance, high availability and high scalability.  Compaq provides the highest levels of
scalability in the industry on Intel platforms.  In an effort to provide cost-effective, high
performance, next generation servers Compaq routinely provides opportunities for you to upgrade
in-chassis or migrate to new chassis from your existing server platforms.

This white paper will provide you with general software preparation and restoration procedures
necessary to upgrade or migrate your hardware in a Windows NT 4.0 environment.  This white
paper will assist you in upgrading components in the same chassis or migrating to a new chassis
from your existing server platform.

Before You Begin

When performing an upgrade or migration you may need the following items:

• Compaq SmartStart and Support Software CD (latest version.)

• Compaq Insight Management CD (latest version.)

• Compaq Systems RomPaq Firmware Upgrade Diskette (latest version.)

• Compaq System Configuration utility (latest version.)

• Windows NT 4.0 CD-ROM or Windows NT 4.0 CD-ROM with latest Service Pack.

Note: The information in this white paper was tested on the current version at the time of release.
Compaq SmartStart and Support Software CD v4.2, Compaq Insight Management CD v4.1, and
Compaq Systems RomPaq Firmware Upgrade Diskette v3.15.  When performing the migration or
upgrade you should obtain the latest version at that time.

If you have a problem you can get further information and other help, latest drivers, and
FlashROM images from the Compaq website at www.compaq.com.

Migration Planning
Before migrating or upgrading a new or existing platform, complete a thorough planning session
to outline objectives, develop a migration/upgrade strategy, anticipate unexpected issues and
develop a contingency plan.  This white paper can be used as a guide when performing Compaq
hardware migrations or upgrades.  Before using this white paper you should always search for
other white papers specific to your migration configuration.  For the remainder of this document
the term migration will be used to identify either a migration or upgrade.

To assist with the migration the following migration checklist (Table 1) has been developed as a
guide to identify incompatible items that may require updating.  You should research these items
to identify whether an update is available and/or required.  The information gained through your
research should be used to complete and modify the table.  The completed table can be used as a
checklist for the migration, however it is not all-inclusive for every migration configuration.
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Table 1: Migration Checklist

Component Description Version Requires Update Update Available

Operating System

Processor(s)

Memory

SCSI Controller(s)

Network Card(s)

Windows NT Support
Software (NT SSD)

Compaq Insight
Manager Agents

Table 2 is an example of a completed migration checklist.  It should be used as a reference only.
Version numbers for components used are based on current versions that were available at the
time this white paper was developed; later versions will probably be available.

Table 2: Completed Migration Checklist

Component Description Version Requires Update Update Available

Operating System Windows NT 4.0 SP3 Optional NT 4.0 SP4

Processor(s) Pentium Pro N/A Optional Pentuim II Xeon

Memory 256 MB EDO (DIMM) N/A No

SCSI Controller(s) Compaq Smart 2DH 3.16 Optional 3.19

Network Card(s) Compaq NetFlex 3/P and
Netelligent PCI controller

4.26 No

Windows NT Support
Software (NT SSD)

Windows NT SSD 2.08 Yes 2.10

Compaq Insight
Manager Agents

Compaq Insight Agents 3.5x Yes 4.10

Table 3 Migration Data Form can be used to assist with planning the migration configuration.
The original configuration for the server should be listed in one column and the desired migrated
configuration in the other.  Fill in the blanks for all components that may be affected.
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Table 3: Migration Data Form

Hardware and Software Original Configuration Migrated Configuration

System Processor(s)

Memory

Controllers

Slot 1

Slot 2

Slot 3

Slot 4

Slot 5

Slot 6

Slot 7

Slot 8

Slot 9

Slot 10

Slot 11

Embedded SCSI Port 1

Embedded SCSI Port 2

Embedded SCSI Port 3

Internal Drive Configuration

Drive Cage 1 (Bottom) 6 – 9.1 GB 6 – 9.1 GB

Drive Cage 2 (Middle) 6 – 9.1 GB 6 – 9.1 GB

Drive Cage 3 (Top)

Hardware Fault Tolerance

RAID 1 (Mirroring)

RAID 5

Software Fault Tolerance

Mirror

Stripe Set with Parity

Volume Set

Operating System

File System(s)

Software

Software Preparation
This section provides step-by-step instructions for various phases needed to prepare for migrating
the operating system.  These steps are not provided as a replacement for official documentation,
however it can be used as a reference.
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Back-Up the System

Use the Windows NT Backup program or a third-party backup program to create a tape archive of
the system you are upgrading.  If you are migrating a domain controller, use Server Manager to
synchronize the domain before performing the backup.

IMPORTANT: Make certain that you verify the backup before proceeding.

If you use a third-party backup program that does not have the option to back up the registry,
back up the contents of the following directory:

<%systemroot%>\system32\config
where <%systemroot%> is the directory that contains Windows NT files.

Make certain that files associated with SAM.* and SECURITY.* have been selected.

Prepare for Recovery

Complete the following steps to create software tools for recovery should migration or upgrade
problems arise.

Create an Emergency Repair Diskette

A Windows NT emergency repair diskette can facilitate recovery after some installation
problems. If you have not already done so, create an emergency repair diskette with the Repair
Disk Utility (rdisk.exe) that ships with the operating system.  To create an emergency diskette:

1. Click Start→Run.

2. Type “RDISK /S” and click OK.

3. Click Yes to create a new Emergency Repair Disk.

4. Insert a new diskette into drive A: then click OK.

5. Click Exit and close the RDISK utility program.

Refer to the Troubleshooting chapter of the Microsoft Windows NT Installation Guide for more
details on creating Emergency Repair Diskettes.

Create a Windows NT Boot Diskette

The boot diskette will allow access to a drive with a faulty boot sequence, such as a corrupted
boot sector, corrupted master boot record (MBR), or corrupted boot files.  The boot diskette will
allow you to boot from the shadow of a broken mirror.  Use the boot diskette if problems arise.

To create a Windows NT Boot Disk:

1. Under Windows NT 4.0, format a blank diskette if you have not already done so.
Note:  Make sure the disk has been formatted under Windows NT.  You will be able to
successfully copy the files onto a pre-formatted DOS diskette but you will not be able to boot
using it.
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2. Copy the NTLDR, NTDETECT.COM, and BOOT.INI files from your server boot drive to
the diskette.

NOTE: If the ARC path of your BOOT.INI begins with the multi() syntax instead of scsi()
you do not need the NTBOOTDD.SYS file.  NTBOOTDD.SYS is only required if you are
using the scsi() syntax in the BOOT.INI file.  For example, the following sample BOOT.INI
file does not need NTBOOTDD.SYS.

[boot loader]

timeout=5

default=multi(0)disk(0)rdisk(0)partition(4)\WINNT40

 [operating systems]

multi(0)disk(0)rdisk(0)partition(4)\WINNT40="Windows NT Server Version 4.00"

C:\="MS-DOS"

3. If you boot from a SCSI controller, locate the driver for the SCSI controller that you boot
from and copy this driver to the diskette as NTBOOTDD.SYS.

For example, for the Compaq SMART-2 Array Controller, type:

COPY <drive> SYSTEM32\DRIVERS\CPQARRAY.SYS a:\NTBOOTDD.SYS

where <drive> is your local drive.

OR

if you boot from a non-Compaq controller such as an Olicom PCI 10/100 Adapter, type:

COPY <drive>SYSTEM32\DRIVERS\OCE4XMP.SYS a:\NTBOOTDD.SYS

where <drive> is your local drive.

However, if NTBOOTDD.SYS already exists on your hard drive, copy the existing file.  You
can find the driver name by clicking Start→Control Panel→SCSI Adapters. Click the Device
tab. Select the adapter, then click the Driver tab.

NOTE:  The driver names are usually similar to the manufacturer name. For example:

3COM Etherlink PCI Adapter (3C590) = 3C59X.SYS.

Cabletron E22XX Ethernet Adapter = CTE22.SYS

IBM 10/100 PCI Ethernet Adapter = IBMFE.SYS

UltraStor 14F/14FB/34F = ULTRA14F.SYS

NOTE: If you are unsure which device is your boot device, unable to find the correct driver,
or are using different types of controllers, you can use the Compaq Boot Partition and Boot
Driver Detection Utility. For a copy of the driver and information on using it, see the Compaq
Internet site at:

http://www.compaq.com/partners/microsoft/sysadm.html

OR

Search for Boot Partition and Boot Driver Detection.

IMPORTANT:   Make certain you verify the boot disk before proceeding. To verify the boot
disk, insert the boot diskette into the diskette drive and restart the operating system.
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Save the Disk Configuration

Use the Windows NT Disk Administrator to save the disk configuration to a diskette.  To save the
disk configuration:

1. Click Start→Programs→Administrative Tools→Disk Administrator.

2. Click Partition menu→Configuration→Save.

3. Insert the new formatted diskette into the diskette drive and click OK.

NOTE:  Running the Disk Administrator will write a signature to the disk to help ensure that
the proper drive letter and order is retained. You can also use Disk Administrator to save and
print the disk configuration to preserve valuable hard drive information in case the need to
restore arises.

Print the Disk Configuration

Create a printout of the Disk Administrator screen to save a paper copy of the hard drive
configuration information.  To print the Disk Administrator screen:

1. Click Start→Programs→Administrative Tools→Disk Administrator.  Choose Yes if
prompted to write a signature to the Disk. The following screen will appear:

2. Select the View menu→Disk Configuration.

3. Adjust the screen size to view as much disk data as possible.

4. Press and hold down the Alt + Print Scrn key to copy data to the clipboard.
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5. Open Microsoft WordPad, Microsoft Paint, or other word processor software. From the Edit
menu, select Paste.

NOTE: WordPad is recommended for capturing data on the clipboard.

6. Save and Print the document for later reference.

7. If additional drive data is in Disk Administrator, scroll/adjust the screen to display additional
data, then repeat steps 2 d - f. Repeat this process until all the data has been captured. Data
can be saved in one file.

8. To obtain a print out in volumes view, select the View menu, then Volumes and repeat steps
2 c – f.

Update Support Software, Insight Agents and Install
HAL Recovery

If you are currently using Compaq Support Software or Compaq Insight Agents update to the
latest versions.  You should also install the latest version of the HAL Recovery utility to assist
should problems arise during the migration.  If you are not updating the support software
complete steps 1, 2, and 3 under the Update Support Software section and then skip to step 5
under the section entitled “Install HAL Recovery”.

Update Support Software

To update to Compaq Support Software for Windows NT 4.0 version 2.08 or higher from the
Compaq SmartStart Software Support CD v4.20 or later; complete the following steps:

1. Insert the Compaq SmartStart and Support Software CD.

2. Click Start→Run.

3. Enter <drive>:\CPQSUPSW\NTSSD\SETUP.EXE

where <drive> is the drive letter of your CD-ROM drive.

4. Select the installed option(s) under Computer Name and click Update, if applicable.

NOTE: The Express option rapidly updates all support software.

Install HAL Recovery

Complete steps 5-7 to install the HAL Recovery option.  This will assist with troubleshooting
should problems arise.

5. Select the HAL Recovery Option, then click the Install button.

NOTE: The following step requires a Windows NT Server CD or disk with the Windows NT
HAL and kernel files.

6. Select Multiprocessor HAL and Kernel, then click the Downgrade button.

7. From the Main menu, select Exit. Select Yes to reboot the server.
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Update Insight Manager Agents

Compaq Insight Manager (CIM) Agents are upgraded using the Compaq Management CD. To
upgrade Insight Agents for Windows NT using the Compaq Management CD:

1. Insert the Compaq Management CD into the CD-ROM drive.

2. Using Windows NT 4.0, click Start→Run.

3. Enter < drive>:\AGENTS\WIN-NT\ENG\SETUP

where <drive> is the CD-ROM drive.

4. A dialog box containing the Update option and Remove and Reinstall option displays.  Select
the Update button.

5. Follow the instructions on the screen. If needed, press F1 for online help.

Document Operating System Settings

Recording the network settings before upgrading or migrating can be useful after the upgrade or
migration to restore the system to its original configuration.  You should perform this step if your
upgrade or migration requires you to add, rearrange or remove SCSI or network controllers.  Two
methods exist to record this information, however Method 1 is recommended.  Instructions on
using Method 1 have been provided below.

Method 1: Save network settings to a file on the System Settings diskette(s) as text or screen
shots cut and pasted to a word processing application.

Method 2: Record network settings specific to each network interface controller port on paper.

Note: If you are adding, rearranging or removing SCSI or network controllers, at minimal you
should document (write down) the network controller number and it’s associated IP address.  This
will help ensure that the system has been properly restored and/or used to restore the network
settings should problems arise.  To do so click Start→Settings→Control Panel→Network
icon→Protocol tab→TCP/IP Protocol→Properties, write down the network adapter number,
name and specified TCP/IP address.  For example:

Adapter # Adapter Name/Description TCP/IP address

[1] NetFlex 3/P 10 T UTP –BNC Module Slot 7 Bus 127.0.0.1

[2] NetFlex 3/P 10 T UTP –BNC Module Slot 6 Bus 255.255.255.0

The following steps will capture all data that can be referenced for recovery of network settings,
if problems arise.

1. Click Start→Settings→Control Panel→Network icon.

2. Select the Identification tab.  The following screen appears:
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3. Press and hold down the Alt + Print Scrn keys; this will copy the data to your clipboard.

NOTE:  Do not close the dialog box; minimize if necessary.

4. Open Microsoft WordPad, Microsoft Paint, or other word processor installed on your system.
From the Edit menu, select Paste.

NOTE: WordPad is recommended for capturing data on the clipboard.

5. Save the file. Press the End key, then press the Enter key twice to add space for the next
screen capture.

6. Return to the Network dialog box.

7. Press the Protocols tab, select the first protocol on the list, and then click the Properties
button if it is available. Copy and paste all information to the file saved in Step 5.

8. Repeat step 7 for all protocols.

9. Select the Bindings tab. For Show Bindings click All Protocols.  Expand each protocol and
scroll to the top of the dialog box. Copy and paste all Bindings information to the file.
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It may be necessary to scroll down to display remaining Bindings information, continue this
process until all data has been captured and saved.  See the following example.
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10. Print the file if a printer is available, then copy the file to diskette and place it in a safe place.

Verify Proper Operation

After completing all of the above procedures, restart your software operating system and
applications to verify that they are operating properly.

CAUTION:   Do not proceed to the system preparation section unless the software and server are
operating properly.

If the server is operating properly, power it off and proceed with the system preparation portion
of this document.

System Preparation
This section will provide information on updating your firmware, system partition files and
utilities, recording your system configuration using the Compaq System Configuration Utility,
and documenting and printing system configuration reports.
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Update Firmware

Compaq servers and most Compaq options have onboard firmware (operating program in ROM).
Updating firmware is done by flashing the ROM using a special Compaq utility called a ROMPaq
to replace the existing contents of the ROM with another version stored in a file on a floppy
diskette.

There are two ROMPaq utilities:

• System ROMPaq Used for updating the system ROM in all Compaq servers supporting Flash ROM.  Use
System ROMPaq when upgrading Compaq hardware to be sure that the server can utilize
all the capabilities of the new hardware.

• Option ROMPaq Used for updating the onboard ROM on all Compaq options that support flashing.  Use
Option ROMPaq when new versions of Compaq options firmware become available to take
advantage of expanded capabilities.

Note:  Before you install the new hardware in your server, you must run System ROMPaq to
update the system firmware.  This will ensure that the server will recognize the new hardware and
not hang on boot.

ROMPaq Diskettes

The ROMPaq utilities must be run from diskette.  The latest version of the ROMPaq diskettes
may be created from the SmartStart and Support Software CD that was supplied with your new
Compaq hardware.  We recommend that you initially use this version of ROMPaq because it is
the latest one that supports your new Compaq equipment.

To run the System ROMPaq:

1. Place the System ROMPaq diskette in the server diskette drive.

2. Boot the server by turning on the power.

3. Press Enter at the Welcome screen.

4. At the Select A Device screen, select the server from the list of programmable devices.  This
may be the only item in the list.  Press Enter.

5. At the Select An Image screen you will see:

Device to reprogram: your server
Current ROM revision: date of existing ROM version
Select Firmware Images: date of latest ROM version

Press Enter.

6. Review the information on the Caution screen:

Device to reprogram: your server
Current ROM revision: date of existing ROM version
Select Firmware Images: date of latest ROM version

7. Press Enter to reprogram the system ROM or Esc to discontinue reprogramming and return to
the Select An Image screen.

“Reprogramming Firmware” indicates that the system ROM is being reprogrammed.  DO
NOT INTERRUPT.
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Note:  Do not interrupt this cycle.  Interrupting the ROM reprogramming will leave the
firmware in an unknown state.  You may not be able to boot the server if this happens.  You
will be notified that reprogramming is completed.

8. When ROMPaq is finished reprogramming the system ROM, press Esc to exit the System
ROMPaq Utility.

9. Remove the System ROMPaq diskette and reboot the server by cycling the power (cold boot).

Update Your System Partition

If a system partition is not present then skip the “Update Your System Partition” section.  Proceed
to “Recording Your Configuration Using the Configuration Utility” section.

There are two methods to update your system partition on a configured system that has a system
partition, you can update from CD or diskette.  This white paper will only discuss updating from
CD you should be using the Compaq SmartStart and Support Software CD version 4.1 or later.

To update using the Compaq SmartStart Software Support CD:

1. Insert the Compaq SmartStart Software Support CD into the CD-ROM drive and restart your
system.

2. Select Update System Partition from the Compaq System Utilities menu.  Click Next then
Continue, which restarts the system.

3. After the system restarts, select Compaq System Configuration from the Upgrade Utility
Selection Panel.  This copies the new information onto the system partition.  The system will
restart and display the Smart Start screen.

4. Click Exit SmartStart, Next, Continue.

5. Power off the system.

Record Your System Configuration

Follow these steps to document the system configuration using the Compaq System
Configuration Utility.  Accurately recording your system configuration is crucial to the successful
operation of your server after hardware upgrade procedures have been performed.  Manually
recording your server configuration settings will aid you in the event that the settings recorded by
the configuration utility become damaged.

1. Insert the Compaq SmartStart Software Support CD into the CD-ROM drive and restart your
system.

2. Select Run System Configuration Utility and choose Next, then Continue.

3. Select System Configuration from the Main menu.

4. Select Configure Hardware and then press enter.  Select Review or modify hardware settings.

5. Select Step 4: Examine switches and print report from the Steps in configuring your computer
menu and press enter.

6. Press F7 and select either Print All Configuration Settings, if a printer is attached, and/or
Print All Configuration Settings to a File, which you can print at a later time.  Follow the
instructions on the screen.  Save the print-out for future reference.  Choose F10 to return to
the Steps in configuring your computer menu.
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7. Choose View or Edit details and then press enter.  Page Down to each embedded controller to
document (write down) the controller order and briefly describe any attached devices. This
will assist in differentiating between multiple connectors on a given SCSI controller
expansion board.

IMPORTANT: It is not necessary to record all attached devices.  Pay close attention to the
installed devices to verify settings to restore your server to its original configuration.

Document (write down) the controller order and slot numbers for remaining SCSI controllers
and Fibre channel controllers to aid in the restoration of your server to it’s original
configuration.

8. Press F10 to return to the Steps in configuring your computer menu.

9. Select Step 5: Save and Exit from the Steps In Configuring Your Computer menu.

10. Select Save the Configuration, and Restart the Computer and press enter.

11. Remove the CD from the drive and press enter at the reboot message, then power off the
server.

Verify Proper Operation

After completing all of the above procedures, restart your software operating system and
applications to verify that they are operating properly.

CAUTION:   Do not proceed to upgrade your hardware unless the software and server are
operating properly.

If the server is operating properly, power it off and proceed with the hardware upgrade or
migration.

Software Restoration
This section provides steps to restore your system and operating system settings.  After you
hardware or component migration has been completed, you may use one or all of these steps to
restore your operating system to its original state.

Restore the System

Use the System Configuration Utility restore your system.  This step will ensure that the
controller order is set properly to allow the operating system to load

1. Insert the Compaq SmartStart Software Support CD into the CD-ROM drive and restart your
system.

2. Select Run System Configuration Utility and choose Next, then Continue.

3. Select System Configuration from the Main menu.

4. Select Configure Hardware and press enter.  Select Review or modify hardware settings.

5. Choose View or Edit details and press enter.  Page Down to each controller and verify that
the controller order is correct.  Use the information documented during the “Record Your
System Configuration” section of this white paper and/or the migrated configuration column
in Table 3: Migration Data Sheet.

6. Press F10 to return to the Steps in configuring your computer menu.
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7. Select Step 5: Save and Exit from the Steps In Configuring Your Computer menu.

8. Select Save the Configuration, and Restart the Computer and press enter.

9. Remove the CD from the drive and press enter at the reboot message, and then power off the
server.

Restore Network Settings

This section provides steps to restore your network card settings.  The order in which these steps
should be used will vary according to the migration or upgrade you are performing. Network
drivers for Network Interface Controllers (NICs) may become unbound if you have added a
bridged controller of any type.  If you are unsure use the steps below to verify whether or not the
NIC has become unbound.  You can use the Compaq Advanced Network Control Utility or the
Microsoft Network Application located in the Control Panel to reinstall or re-bind the drivers.
Additional installation instructions can be found in the Windows NT documentation or the NIC
documentation.

1. Load Windows NT.

2. Choose the Start menu -> Settings -> Control Panel -> Compaq Net icon to launch the
Advanced Network Control Utility.  Proceed to step 3 if you are not using a Compaq
NetFlex-3 driver, are using non-Compaq drivers, or the following steps were unsuccessful.
The Unbound Services screen will be displayed when a change is made to the configuration
that affects the network bindings.

To correct the problem you may be able to bind the registry entry using the following steps:

a. Highlight the listing under Unbound services and the first adapter under Available
adapters.

b. Click the Bind button to attach the driver to the controllers.

c. When the configuration is complete, and you are prompted to reboot, choose Yes to
reboot the server.  This shutdown will simplify troubleshooting should problems arise.
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d. After you reboot the server verify that the network adapter numbers and TCP/IP
addresses match what was documented in the Document Operating System Settings
section of this white paper.

3.  Choose the Start menu -> Settings -> Control Panel -> Network icon.  Choose the Adapters
tab and choose the Add button and select the appropriate driver from the list to re-add NICs
previously installed. Highlight the NIC that did not load and select the Remove option.

Use the captured data from the floppy or print-out to restore all settings in the Network
settings dialog box.

4. When the configuration is complete and you are prompted to do so, choose Yes to reboot the
server.  This shutdown will simplify troubleshooting should problems arise.

Upgrade the HAL

If you downgraded the HAL in Phase 2 and are using multiple processors complete the following
steps to upgrade HAL from uniprocessor to multiprocessor:

1. Insert the Compaq SSD for Windows NT Diskette #1 into the diskette drive.

2. Click Start→Run.

3. Type a:\SETUP (where a: is the letter of the diskette drive), and click OK.

4. Select Multiprocessor HAL and Kernel, then click the Upgrade button.

5. Choose the Main menu and Exit; click Yes to Reboot so that the modifications will take
effect.

Verify System Operation

After completing configuration of your software, restart your server and verify that your software,
applications, and server are operating properly. Check network connections, Event Viewer and
data for functionality.

Troubleshooting
This section provides troubleshooting information specifically related to Windows NT.

Errors, Issues, and Workarounds

Table 4 provides error messages, issues, and workarounds to problems that may be encountered
when performing the migration.

Table 4: Errors, Issues, and Workarounds

Error/Symptom(s) Workarounds

Server cannot load operating system/ Windows NT does
not boot.  Non-system disk error.

Controller order incorrect.  If problem occurs after the
hardware replacement process:

Run the System Configuration Utility and check the
controller order for the boot device.  Make sure the boot
device controller order is set too first.

If problem occurs before the hardware replace process:

Make sure all floppy disks have been remove from a:.
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Run the Emergency Repair Disk.  See the Windows NT
documentation for additional instructions.
Document any error messages and changes since the
last successful boot.

Windows NT Service Control Manager error: At least one
drive failed during system startup.

Video driver and/or network drivers did not start.  Check
Event Viewer and record the Event ID and the
Description.  See specific Event Ids listed below.

Event ID: 7026
Description: The following boot-start or system start
driver(s) failed to load:<device or driver name>

This driver or device may no longer be used.  If this is the
case go to Settings, Control Panel, Devices, select
<device name> and choose the Startup button.  Change
the startup to disabled.

Event ID: 4105
Description: <Adapter name>: Network link is down.

or

Event ID: 5003
Description: <Adapter Name>: Could not find an adapter

The PCI bus number may have changed. The driver may
have become unbound.  You must reinstall the network
drivers.  Use the Advanced Network Control Utility, Start
menu, Settings, Control Panel, Compaq Net icon or Start
menu, Settings, Control Panel, Network icon.

System slow, applications almost halt system. Swap/page file may be corrupt.  Use the System applet
in Control Panel to create a new one..

NTFS.sys or other file missing or corrupt Run the ERD to replace the file, if that does not work run
complete options from the ERD.

NT blue screens with a Stop error or hangs after or
during logon.

Make sure all Compaq Insight Manager (CIM) agents
and Support Software have been updated to the latest
version.

Basic Troubleshooting Strategy

This section lists basic methodology to use when troubleshooting.  First you need to gather
problem/symptom(s), to allow you to isolate and resolve the issue.  In doing so, the following
questions should be asked:

• Is the problem reproducible or random?

• What hardware and/or software are involved?

• Were any errors made in implementing steps?  Was more than one variable changed at a
time?  Watch for and record any mistakes made while executing the steps or the action plan.

• If applicable does the problem occur on the server or is it just client specific?

• Were any steps skipped or completed out of order?  Look for skipped steps or steps executed
out of order.  Circle the steps not executed and number the true order the steps were executed.

• Were any steps accidentally added?  Were any steps added intentionally to complete or
correct another step?  Place checkmarks against the steps as they are/were executed to avoid
this.  If steps had to be added on the fly in order to proceed, record why and where.

• Disable all services not necessary to run the OS and add them back one at a time.  To
determine if one of them is the culprit.

After the above questions have been asked you can complete the following steps to resolve the
issue:

1. Decide on one cause and possible solution at a time.  Make appropriate modifications and
then test those modifications.  Try to minimize the number of things you change between
tests.
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2. Test each modification to see if it fixed the problem.

3. Write down all symptoms, causes, and solutions.  Having a written record makes an excellent
reference for future troubleshooting.

4. Install new copy of the OS into a different directory.  Does the problem still occur?  Add
software and disable all services not mandatory to run the OS.  Add services and software one
at a time to isolate the problem.

Summary
This white paper provides step-by-step instructions, sample migration scenarios, and
troubleshooting tips to successfully upgrade your Compaq ProLiant 6000 or 7000 Pentium Pro
server to Pentium II Xeon technology.  Used in conjunction with the Compaq ProLiant 6000 and
ProLiant 7000 Pentium II Xeon Upgrade guide, this white paper details information for the
Windows NT software preparation and restoration procedures necessary to upgrade.  Detailed
instructions on removing and restoring the server’s hardware and installing upgrade parts are
provided in the Compaq ProLiant 6000 and ProLiant 7000 Pentium II Xeon Upgrade guide.  The
upgrade guide also provides instructions for upgrading servers with other operating systems
installed.


